After I wanted to install a module on my Drupal 9 site, I got this error:

- symfony/string v6.0.8 requires php >=8.0.2 -> your php version (7.4; overridden via config.platform, actual: 7.4.13) does not satisfy that requirement.


Problem was that I was on PHP 7.4. While I knew the module wouldn't be a problem for PHP 7.4, I fixed it by doing: 

composer require drupal/menu_link_attributes --ignore-platform-reqs