Recently I got this error installing Linkit on a Drupal 9.3 website:

  Problem 1
    - symfony/string v6.0.8 requires php >=8.0.2 -> your php version (7.4; overridden via config.platform, actual: 7.4.13) does not satisfy that requirement.
    - drush/drush 11.0.9 requires chi-teck/drupal-code-generator ^2.4 -> satisfiable by chi-teck/drupal-code-generator[2.5.3].
    - chi-teck/drupal-code-generator 2.5.3 requires symfony/string ^5.1 || ^6 -> satisfiable by symfony/string[v6.0.8].
    - drush/drush is locked to version 11.0.9 and an update of this package was not requested.


The solution was to remove composer.lock and then

composer install

After this, I was able to run the command again and Linkit was installed correctly.


Saved you some valuable time?

Buy me a drink 🍺 to keep me motivated to create free content like this!