After upgrading to drupal 9 I had the following error on the linkit module:

Drupal\Component\Plugin\Exception\PluginNotFoundException: The "linkit" plugin does not exist. Valid plugin IDs for Drupal\filter\FilterPluginManager are

The problem seems to be in Linkit version 6.x. Downgrading to 5 made the error vanish:

composer require drupal/linkit:5.0-beta12