Problem

The 'core_version_requirement' key must be present in themes
Drupal\Core\Extension\InfoParserException: The 'core_version_requirement' constraint (^9) requires the 'core' key not be set in themes

Solution

The new core_version_requirement key in *.info.yml files for modules, themes, and profiles now supports semantic versioning as implemented by the Composer project. This allows modules, themes, and profiles to also specify that they are compatible with multiple major versions of Drupal core.

For example a module that is compatible with Drupal 8 and Drupal 9 can have a info.yml file like this

name: My Module
type: module
core: 8.x
core_version_requirement: ^8 || ^9